Unverified Commit d4cd224a authored by azul's avatar azul

vagrant: upgrade apache config to 2.4

The config now lives in /etc/apache2/000-default.conf.
Also changed the allow, deny syntax to Require all granted.
parent 4f859f76
......@@ -12,8 +12,7 @@
DocumentRoot /var/www/default
<Directory /var/www/default>
Order allow,deny
Allow from all
Require all granted
</Directory>
</VirtualHost>
......@@ -28,14 +27,13 @@
DocumentRoot /var/www/app
<Directory /var/www/app>
Order allow,deny
Allow from all
Require all granted
</Directory>
<Location />
AuthType SSO
SSOService app.sso.net/
require valid-user
Require valid-user
</Location>
</VirtualHost>
......@@ -46,8 +44,7 @@
SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
<Proxy *>
Order allow,deny
Allow from all
Require all granted
</Proxy>
ProxyPass / http://127.0.0.1:5002/
......
......@@ -29,15 +29,13 @@ EOF
service ai-sso-server start
# Setup Apache and create website content.
cp /vagrant/apache_config /etc/apache2/sites-available/default
cp /vagrant/apache_config /etc/apache2/sites-available/000-default.conf
a2enmod rewrite proxy_http ssl sso
mkdir -p /var/www/default /var/www/app
echo '<h1>This is the default website</h1>' > /var/www/default/index.html
echo '<h1>This is the protected app</h1>' > /var/www/app/index.html
cat >/etc/apache2/ports.conf <<EOF
NameVirtualHost *:80
Listen 80
NameVirtualHost *:443
Listen 443
EOF
apache2ctl restart
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment