Commit 0636b7bc authored by silver-platter's avatar silver-platter
Browse files

Bump debhelper from old 10 to 12.

+ Use dh_installsystemd rather than deprecated dh_systemd_enable.
+ Use dh_installsystemd rather than deprecated dh_systemd_start.

Changes-By: lintian-brush
Fixes: lintian: package-uses-old-debhelper-compat-version
See-also: https://lintian.debian.org/tags/package-uses-old-debhelper-compat-version.html
parent b220ebce
......@@ -2,7 +2,7 @@ Source: accountserver
Section: admin
Priority: optional
Maintainer: Autistici/Inventati <debian@autistici.org>
Build-Depends: debhelper (>= 9), golang-any (>= 1.14), dh-golang, default-jre-headless, debhelper (>= 9.20160709~) | debhelper-compat | dh-sequence-systemd | | dh-systemd
Build-Depends: debhelper (>= 12~), golang-any (>= 1.14), dh-golang, default-jre-headless
Standards-Version: 3.9.6
Package: accountserver
......
......@@ -9,13 +9,13 @@ export DH_GOLANG_INSTALL_ALL := 1
%:
dh $@ --with systemd --with golang --buildsystem golang
dh $@ --with golang --buildsystem golang
override_dh_auto_install:
dh_auto_install -- --no-source
override_dh_systemd_enable:
dh_systemd_enable --no-enable
override_dh_installsystemd:
dh_installsystemd --no-enable
override_dh_systemd_start:
dh_systemd_start --no-start
override_dh_installsystemd:
dh_installsystemd --no-start
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment