Update go.mod and vendor

'go build .' yields this error otherwise:

  $ go build .
  go: inconsistent vendoring in /tmp/logcat:
  	github.com/olivere/elastic/v7@v7.0.19: is explicitly required in go.mod, but not marked as explicit in vendor/modules.txt

  run 'go mod vendor' to sync, or use -mod=mod or -mod=readonly to ignore the vendor directory
2 jobs for gomod in 54 seconds
Status Name Job ID Coverage
  Build Pkgsrc
passed build_pkgsrc:buster #20662

00:00:24

 
  Build Pkg
passed build_pkg:buster:amd64 #20663
amd64

00:00:29