Skip to content
Snippets Groups Projects
rules 1.32 KiB
#!/usr/bin/make -f
# -*- makefile -*-
# Sample debian/rules that uses debhelper.
#
# This file was originally written by Joey Hess and Craig Small.
# As a special exception, when this file is copied by dh-make into a
# dh-make output file, you may use that output file without restriction.
# This special exception was added by Craig Small in version 0.37 of dh-make.
#
# Modified to make a template file for a multi-binary package with separated
# build-arch and build-indep targets  by Bill Allombert 2001

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1

# This has to be exported to make some magic below work.
export DH_OPTIONS

export PYBUILD_NAME=authserv

PAM_INST_DIR = $(CURDIR)/debian/tmp/lib/$(DEB_HOST_MULTIARCH)/security

%:
	dh $@ --with python2 --buildsystem=python_distutils

override_dh_auto_build:
	(cd pam && ./autogen.sh && ./configure --prefix=/usr --with-pam-dir=/lib/$(DEB_HOST_MULTIARCH)/security && make)
	dh_auto_build

override_dh_install:
	install -d $(CURDIR)/debian/tmp/etc
	install -o root -g root -m 644 $(CURDIR)/debian/ai-auth-server.conf \
	  $(CURDIR)/debian/tmp/etc/ai-auth-server.conf
	(cd pam && make install DESTDIR=$(CURDIR)/debian/tmp)
	rm -f $(PAM_INST_DIR)/pam_authclient.so{,.0}
	mv $(PAM_INST_DIR)/pam_authclient.so.0.0.0 \
	   $(PAM_INST_DIR)/pam_authclient.so
	dh_auto_install
	dh_install